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Contact your Authorized Curtain Reseller or Service Provider to report problems 
and/or provide feedback. 

 

Additional help resources or updates will be available by emailing 
info@coworkshop.com  
 

Coworkshop Solutions Ltd. reserves the right to make changes to this document 
and to the product described herein without notice. The software described in 

this manual is furnished under the terms and conditions of the Curtain Software 
License Agreement and may be used or copied only in accordance with the terms 
of the agreement. 

 
For information about your legal rights concerning the use of the Curtain 

MonGuard, please refer to the Curtain Software License agreement.  
 
© 2002-2021 Coworkshop Solutions Ltd. All Rights Reserved. Curtain belongs to 

Coworkshop Solutions Ltd. All other brand names, product names, or trademarks 
belong to their respective holders.  
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1 - Introduction

1.1 - Challenges of Data Leakage through Computer's Screen

In everyday operations, users have access to and work on sensitive files.  However, it is difficult for 

companies to prevent users taking photo/video against computer's screen by using mobile phone when 

accessing sensitive information (e.g. personal information, CCTV footage and other sensitive data). Due to 

COVID-19, more and more people work from home. Companies have to allow users to download data to 

notebook and access the data at home or allow them to connect to company's network through VPN. It 

increases the difficulty of preventing data leak through screen. 

Online meeting is another security challenge. When people need to show something to meeting 

participants (e.g. contracts, designs and even training materials) during online meeting, how to protect the 

information shown to participants? Although we cannot prevent people to take photo/video against 

computer's screen, at least we should be able to trace the source of data leakage.

1.2 - What is the purpose of Curtain MonGuard?

Curtain MonGuard is a Data Loss Prevention (DLP) solution, which allow administrators to display 

watermark on screen in user's computers. Since this screen watermark can show user information (e.g. 

computer name, username and IP address), it effectively gets user's attention before they capture screen 

and share the information with other people.

1.3 - Components of Curtain MonGuard

There are 2 basic components of Curtain MonGuard:

Curtain MonGuard Client


Curtain MonGuard Admin (for the machine having Curtain MonGuard Admin, we call it Curtain 


Policy Server)

Curtain MonGuard Client:

When administrators want to display watermark on screen in user's computers, Curtain MonGuard Client 

must be installed in those computers. 

Curtain MonGuard Admin:

Curtain MonGuard Admin is mainly for administrators to define Curtain control policies centrally. In 

general, only one Curtain MonGuard Admin is needed in a company.

P.S.  

- Curtain MonGuard Admin can be installed on physical machine or virtual machine (VM).

- For standalone computer, Curtain MonGuard Admin and Client can be installed on the same machine. It is 

recommended to enable password protection for Curtain MonGuard Admin for preventing users to 

change control policy.
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2 - Preparation before Installation

2.1 - High-level Installation Plan

Preparation:

Which computers do you want to display watermark on screen?


What kind of screen watermark do you want to apply (e.g. Full Screen Watermark or Application 


Screen Watermark)?

Duration of displaying screen watermark (e.g. always or specific time slot)?


Which server will act as Curtain Policy server (i.e. Curtain MonGuard Admin will be installed on 


that server)?

Do you want to integrate Curtain MonGuard with Active Directory (so that control policy can be 


granted to AD user/user group)?

High-level installation plan:

1. Install Curtain MonGuard Admin

2. Install Curtain MonGuard Client on user's workstations

3. Activate Curtain MonGuard

4. Define format of screen watermark

5. Create and configure control policy groups in Curtain MonGuard Admin

6. Connect with Active Directory for collecting user information, if you prefer to grant control policy by 

user/user-group

7. Assign workstations/users to different policy groups

8. Done

Related FAQs:

FAQ00318 - What are the basic components of Curtain MonGuard?

FAQ00308 - How to activate Curtain MonGuard? 

FAQ00305 - How to define format of screen watermark?

FAQ00303 - How to grant control policy by user/user group?

FAQ00302 - How to configure Control Policy Group?

2.2 - System Requirements of Curtain MonGuard Admin and Client

System Requirements of Curtain MonGuard Admin and Client:

Intel Pentium or above processor


Windows XP 32-bit/Server 2003 32-bit/2008 32-bit/2008 64-bit 


SP2/2012/2012R2/2016/2019/Vista 32-bit/Win 7 32-bit/Win7 64-bit SP1(with KB3033929)/Win 

8/Win 8.1/Win 10 operating system

128MB RAM (Recommended 256MB RAM)


200MB Hard Disk (in NTFS) for installation


TCP/IP network


TCP Port 8443 (Default Enable)


TCP Port 24821 and 24822 are opened for communication (Note: if firewall exists in the network, 


please make sure these two communication ports are not disabled)

For 64-bit OS, MSXML 4 or 6 is required (It can be download from Microsoft website)

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3 - Installation

3.1 - Install Curtain MonGuard Admin

After you decide which server acts as Curtain Policy server, you should install Curtain MonGuard Admin on 

that server.  Here are the steps.

Steps to install Curtain MonGuard Admin:

1. Copy appropriate Curtain server setup package (e.g. CurtainMonGuardAdmin_Win32(327400).zip or 

CurtainMonGuardAdmin_X64(327400).zip) to local hard-disk of the server.

2. Unzip the setup package.

3. Run Curtain server setup program. Make sure that you login Windows with administrator right.

Then, you will be asked to select Language for the installation.

4. Select a language and click OK.

5. Read License Agreement.  If you accept the agreement, select "I accept the terms of the license 

agreement" and click Next to continue.
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Then, you will be asked to select Curtain components to install.

6. By default, "Curtain Admin" is selected. Click Next to continue.

7. Select Destination Folder for the installation, and click Next to continue.

8. Click Install to start the installation.

9. Please reboot the server after the installation.

3.2 - Install Curtain MonGuard Client

If you want to display watermark on screen in a user's workstation, you should install Curtain MonGuard 

Client on that.  Here are the steps.

Steps to install Curtain MonGuard Client:

1. Copy appropriate Curtain MonGuard client setup package (e.g. 

CurtainMonGuardClient_Win32(327400).zip or CurtainMonGuardClient_X64(327400).zip) to local hard-disk 

of user's workstation.

2. Unzip the setup package.

3. Run Curtain MonGuard client setup program. Make sure that you login Windows with administrator 

right.

Then, you will be asked to select Language for the installation.
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4. Select a language and click OK.

5. Read License Agreement.  If you accept the agreement, select "I accept the terms of the license 

agreement" and click Next to continue.
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Then, the setup program will check your system environment for the installation, click Next to continue.
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6. Enter hostname or IP Address of Curtain MonGuard Admin (Please make sure that it is entered correctly), 

and click Next to continue.

7. Select Destination Folder for the installation, and click Next to continue.

8. Click Install to start the installation.

9. Reboot the workstation after installing Curtain MonGuard Client.

P.S.  There is no user interface for Curtain MonGuard Client. You can find it in Windows control panel.
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4 - Product Activation

4.1 - Activate Curtain MonGuard

Curtain MonGuard is a shareware. Users can download and use the software for free on a trial basis. If users 

want to display [username] and [IP address] in screen watermark, they need to activate the software to paid 

version.

Steps to activate Curtain MonGuard:

1. In Curtain MonGuard Admin, select "Help > About Curtain MonGuard Administrator". Then, the 

following dialog will appear.

2. Click "Activate MonGuard", you will be asked to do the activation.

3. Click Yes to start Product Activation (or click No to skip the Activation).

If it is the first time you activate the software, you will be asked to enter a 25-character Product 


Key. 

If it is the Annual Product Reactivation, please go to Step 5 to continue.

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4. Enter Product Key (which is case sensitive) and company information, and click OK to continue.  Then, the 

following dialog will appear.

5. Click "Generate Request file..." button to generate Activation Request File, and send this file to 

Coworkshop (registration@coworkshop.com). After receiving your activation request, Coworkshop will 

send Confirmation Code file back to you.

6. After receiving Confirmation Code file from Coworkshop, click "Import Confirm File..." button and select 

the file.  After you click OK, the following message box will appear.

Congratulations! Curtain MonGuard has been activated successfully.
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5 - Configurations

5.1 - Define format of Screen Watermark

Administrators can define the way how screen watermark display in user's workstations, such as content of 

watermark, font size, transparency, and etc.  Please follow below steps to define the format.

Steps to define format of screen watermark:

1. In Curtain MonGuard Admin, select "File > Settings".

2. In Screen Watermark tab, select "Enable Text Watermark" 
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Color: Color of screen watermark


Font Size: Font size of screen watermark


Font: Font of screen watermark


Font Style: Text Style of screen watermark (Hollow or Solid)


Display Mode: Display mode of screen watermark (Tile or Center). When Tile is selected, the 


whole screen will be filled with screen watermark. If Center is selected, only one screen 

watermark will be shown in the center of screen.

Slope Angle: Slope angle of displaying screen watermark


Refresh Interval: Time interval for refreshing content of screen watermark


Horizontal Space:  In Tile display mode, horizontal space of each screen watermark


Vertical Space: In Tile display mode, vertical space of each screen watermark


Transparency: Transparency for screen watermark


Text Content: Define content of screen watermark here


Text Parameter : Display [DateTime], [Hostname], [IP] and [UserName] in screen watermark


[DateTime]: Date and time
o

[Hostname]: Computer name
o

[IP]: IP address (this parameter is ONLY available in paid version)
o

[UserName]: Windows login username (this parameter is ONLY available in paid version)
o
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3. Click OK button when finish the setup.

4. Done.

Here is an example.
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5.2 - Create Control Policy Group

Administrators can create many Control Policy Groups in Curtain MonGuard for different 

workstations/users.  Here is an example of Control Policy Groups for reference.

- Default Policy: for general users, always display Full Screen Watermark

- Managers:  for senior management, only display Application Screen Watermark for MS Word, Excel, 

PowerPoint and Adobe Reader in office hours

Steps to create Control Policy Group:

1. In Curtain MonGuard Admin, select "File > New Policy" in the menu.  Then you will be asked to enter new 

Policy Name.

2. Enter new Policy Name and click OK to confirm.  

5.3 - Configure Control Policy Group

Steps to configure Control Policy Group:

1. In Curtain MonGuard Admin, select a Policy Group and right-click to select "Properties".
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Here is a summary of settings in a Policy Group. 

Screen Watermark tab

Enable Screen Watermark


Full Screen Watermark
o

Application Screen Watermark
o

Conditions


Always Enable
o

Enable When
o

Advanced Settings tab

Specify some advanced client settings (e.g. duration of keeping debug log)


We focus on Screen Watermark tab here. For other settings, please refer to other FAQs.
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2. In Screen Watermark tab, select "Enable Screen Watermark":

- if you want to display Full Screen Watermark, select "Full Screen Watermark" and go to Step 5 to 

continue.

- if you want to display Application Screen Watermark, select "Application Screen Watermark".

3. Click "Applications" button for enabling screen watermark for specific application(s).

4. Select application(s) which you want to display screen watermark.
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5. Under Conditions:

- if you want to display screen watermark all the time, select "Always Enable" and click OK to save the 

settings.

- if you want to display screen watermark in specific time slot, select "Enable When" and click "Add" button 

for adding time slot (multiple time slots are supported).

6. Enter time slot information and click OK.
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5.4 - Set Default Policy

If a Control Policy Group is set as default policy, all newly installed Curtain MonGuard Clients will fall into 

that Policy Group.  A green tick indicates which Policy Group is default policy.  If it is the first time to launch 

Curtain MonGuard Admin (after the installation), "Default Policy" is set as default policy.

There are two built-in Control Policy Groups. 

- Default Policy

- Wait for Assignment

When Curtain MonGuard Clients have been installed in user's workstations, they will connect to Curtain 

MonGuard Admin and apply default policy.

Steps to set a Control Policy Group to default policy:

1. In Curtain MonGuard Admin, select a Control Policy Group and right-click.  Then a menu will be shown.

2. Select "Set as default policy"

3. Done
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5.5 - Grant control policy by user/user group

Control policy of Curtain MonGurard can be applied to computer or user/user group.  If you prefer to grant 

control policy by AD user/user group, you need to connect with AD for importing user information to 

Curtain MonGuard Admin. When the first time Curtain MonGuard Admin gets a user information, the 

system will use default control policy for controlling that user/user group.  Administrator needs to assign 

the user/user group to appropriate control policy group manually.

To grant control policy by user/user group, please follow steps stated below to enable "Assignment of 

User" in Curtain MonGuard Admin.

Steps for enabling "Assignment of User" in Curtain MonGuard Admin:

1. Launch Curtain MonGuard Admin, open File -> Settings -> Assignment of Security Policy.

2. Choose "Assignment of User", and click "OK" button. 

Then "User And Group" will be shown in Curtain MonGuard Admin.

3. Done. 
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Steps for importing users and user groups from AD domain:

1. Launch Curtain MonGuard Admin, open File -> Settings -> LDAP.

2. Check "Enable LDAP" button.

3. Enter LDAP server address, DNS or IP address on "LDAP Server Address".

4. "LDAP Server Port", default port is 389.

5. Recommend to enable "Use Secure LDAP Connection", it means to use secure LDAP connection to AD 

(default is disable).

6. Enter user name on "LDAP Username"  to connect LDAP server.

7. Enter password on "LDAP Password".

8. "LDAP Search Base", enter the root of user or group , should enter CN, OU and DC .

for search the whole domain, enter "dc=domain name,dc=domain suffix" (e.g. 


"dc=test,dc=com")

for search the whole group, enter "ou=organizational unit name,dc=domain name,dc=domain 


suffix" (e.g. "ou=it,dc=test,dc=com")

for search single user, enter "cn=username,ou=organizational unit name,dc=domain 


name,dc=domain suffix" (e.g. "cn=tester,ou=it,dc=test,dc=com")

9. "LDAP Information Caching", for setup caching information of AD (default is 15 minutes).

10. While setting is finished, click "Test connection" button to see whether connect to AD successfully or 

not.
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11. If AD user/user group is imported to Curtain MonGuard Admin successfully, they will be shown under 

"User And Group" in Curtain MonGuard Admin as below.

12. Done.

Steps to assign users/user groups to different Control Policy Groups: 

1. In Curtain MonGuard Admin, select User/Group in left panel. Then, Users/Groups will be listed out in the 

right panel. 

2. Select users/groups (press Ctrl button for multiple selection).

3. Right click and select "Change Policy" to assign users/groups to appropriate Control Policy Group.
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4. Repeat Step 2-3 for assigning other users/groups to appropriate policy groups. 

5. Done.

5.6 - Assign workstations/users to Control Policy Group

Steps to assign workstations to different Control Policy Groups:

1. In Curtain MonGuard Admin, select Online/Offline in left panel.  Then, workstations will be listed out in 

the right panel.

2. Select workstations (press Ctrl button for multiple selection)

3. Drag and Drop selected workstations to appropriate Control Policy Group
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4. Repeat Step 2-3 for assigning other workstations to appropriate policy groups.

5. Done

Steps to assign users to different Control Policy Groups:

1. In Curtain MonGuard Admin, select User/Group in left panel. Then, Users/Groups will be listed out in the 

right panel. 

2. Select users/groups (press Ctrl button for multiple selection).

3. Right click selected users/groups, choose "Change Policy" and assign users to appropriate Control Policy 

Group.
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4. Repeat Step 2-3 for assigning other users/groups to appropriate policy groups. 

5. Done.


